Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8055838

Hotspot does not compile with clang 6.0 (OS X Yosemite)

    Details

    • Subcomponent:
    • Resolved In Build:
      b31

      Backports

        Description

        There is a check in the makefiles for versions of clang to lower the optimization level. This check needs to take clang 6.0 into account. The straightforward fix is below, however, we should probably verify if the lower optimization is still needed.




        diff -r 8e575cec7af9 make/bsd/makefiles/gcc.make
        --- a/make/bsd/makefiles/gcc.make Tue Aug 19 11:17:44 2014 -0700
        +++ b/make/bsd/makefiles/gcc.make Fri Aug 22 19:06:41 2014 +0200
        @@ -325,6 +325,10 @@
           else ifeq ($(shell expr $(CC_VER_MAJOR) = 5 \& $(CC_VER_MINOR) = 1), 1)
             OPT_CFLAGS/loopTransform.o += $(OPT_CFLAGS/NOOPT)
             OPT_CFLAGS/unsafe.o += -O1
        + # Clang 6.0
        + else ifeq ($(shell expr $(CC_VER_MAJOR) = 6 \& $(CC_VER_MINOR) = 0), 1)
        + OPT_CFLAGS/loopTransform.o += $(OPT_CFLAGS/NOOPT)
        + OPT_CFLAGS/unsafe.o += -O1
           else
             $(error "Update compiler workarounds for Clang $(CC_VER_MAJOR).$(CC_VER_MINOR)")
           endif

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  sla Staffan Larsen (Inactive)
                  Reporter:
                  sla Staffan Larsen (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: