Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8059941

[D3D] The fix for JDK-8029253 should be ported to d3d pipeline

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
      2d
    • Resolved In Build:
      b40
    • CPU:
      generic
    • OS:
      windows

      Backports

        Issue Links

          Activity

          serb Sergey Bylokhov added a comment - - edited
          This bug is not found in d3d, because this pipeline has D3DSwToSurfaceScale(SurfaceType.IntArgb) which is absent in ogl pipeline. But for some another types the new blit D3DGeneralTransformedBlit is still useful.
          Difference is 30 seconds vs 25 ms

          Test for verification:
          test/java/awt/image/DrawImage/UnmanagedDrawImagePerformance.java

          additional java option: -Dsun.java2d.d3d=True
          iris Iris Clark added a comment -
          If the changeset includes the addition of this bugid to the @bug list in the covering regression test (UnmanagedDrawImagePerformance.java), then the "noreg*" Label can be removed.
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/client/jdk/rev/12ab3aed2ba5
          User: serb
          Date: 2014-10-23 16:01:07 +0000
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/jdk9/jdk/rev/12ab3aed2ba5
          User: lana
          Date: 2014-11-17 19:26:12 +0000

            People

            • Assignee:
              serb Sergey Bylokhov
              Reporter:
              serb Sergey Bylokhov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: