Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8061322

Regression - Java 8u25 x86 doesn't work after installation

    Details

    • CPU:
      x86_64
    • OS:
      windows_7
    • Verification:
      Verified

      Description

      FULL PRODUCT VERSION :
      Throws the following exception:
      Error occurred during initialization of VM
      java.lang.NoClassDefFoundError: java/nio/charset/IllegalCharsetNameException
               at java.io.PrintStream.toCharset(Unkown Source)
               at java.io.PrintStream.<init>(Unkown Source)
               at java.lang.System.newPrintStream(Unkown Source)
               at java.lang.System.initializeSystemClass(Unkown Source)

      ADDITIONAL OS VERSION INFORMATION :
      Microsoft Windows [Version 6.1.7601]

      EXTRA RELEVANT SYSTEM CONFIGURATION :
      We setup this plain Windows 7 x64 VM to reproduce a Java Problem which exists on all our Windows 7 machines in case of the x86 JRE 8u25 installation

      A DESCRIPTION OF THE PROBLEM :
      One of our testers wasn't able to start our java webstart application by using the new Java 8u25 32bit VM. Therefore we setup a plain Windows 7 x64 VM to reproduce that problem. We only installed the JRE 8u25 32bit version.

      The problem still exists on our plain Windows 7 VM and in addition we get the following exception if we call java -version:

      Throws the following exception:
      Error occurred during initialization of VM
      java.lang.NoClassDefFoundError: java/nio/charset/IllegalCharsetNameException
               at java.io.PrintStream.toCharset(Unkown Source)
               at java.io.PrintStream.<init>(Unkown Source)
               at java.lang.System.newPrintStream(Unkown Source)
               at java.lang.System.initializeSystemClass(Unkown Source)


      The JRE 8u25 x64 installation works without any problems.

      From my point of view is this bug a REGRESSION, give it a high priority.

      REGRESSION. Last worked in version 8u20

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      1) Setup a plain Windows 7 64bit VM

      2) try to start the Webstart example:
      http://docs.oracle.com/javase/tutorial/deployment/webstart/examplesIndex.html
      -> a dialog comes up with the following message: "A Java Exception has occured."

      3) execute java -version from the command line
      -> the following exception will be thrown:
      Error occurred during initialization of VM
      java.lang.NoClassDefFoundError: java/nio/charset/IllegalCharsetNameException
               at java.io.PrintStream.toCharset(Unkown Source)
               at java.io.PrintStream.<init>(Unkown Source)
               at java.lang.System.newPrintStream(Unkown Source)
               at java.lang.System.initializeSystemClass(Unkown Source)


      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      1) start webstart -> A Java Exception has occured
      2) java -version ->
      Error occurred during initialization of VM
      java.lang.NoClassDefFoundError: java/nio/charset/IllegalCharsetNameException
               at java.io.PrintStream.toCharset(Unkown Source)
               at java.io.PrintStream.<init>(Unkown Source)
               at java.lang.System.newPrintStream(Unkown Source)
               at java.lang.System.initializeSystemClass(Unkown Source)

      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER SUBMITTED WORKAROUND :
      no workaround exists

        Attachments

          Activity

            People

            • Assignee:
              scfitch Stephen Fitch
              Reporter:
              webbuggrp Webbug Group
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: