Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8062901

Iterators is spelled incorrectly in the Javadoc for Spliterator

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8u25
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b48
    • CPU:
      x86_64
    • OS:
      windows_7

      Backports

        Description

        A DESCRIPTION OF THE PROBLEM :
        Iterators is spelled "Iteratorss" in the documentation.

        EXPECTED VERSUS ACTUAL BEHAVIOR :
        EXPECTED -
        Iterators
        ACTUAL -
        Iteratorss

        URL OF FAULTY DOCUMENTATION :
        http://docs.oracle.com/javase/8/docs/api/java/util/Spliterator.html

          Issue Links

            Activity

            dfuchs Daniel Fuchs added a comment -
            The issue is around line #127 in the JDK 9 code base:

             * @apiNote
             * <p>Spliterators, like {@code Iterators}s, are for traversing the elements of
             * a source.
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk9/dev/jdk/rev/1c49c73398b2
            User: psandoz
            Date: 2015-01-21 10:09:19 +0000
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk9/jdk9/jdk/rev/1c49c73398b2
            User: lana
            Date: 2015-01-28 23:16:37 +0000

              People

              • Assignee:
                psandoz Paul Sandoz
                Reporter:
                webbuggrp Webbug Group
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: