Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8067728

Flag::unlock_diagnostic() should be called Flag::clear_diagnostic()

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 10
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b21

      Description

      This method:

      void Flag::unlock_diagnostic() {
        assert(is_diagnostic(), "sanity");
        _flags = Flags(_flags & ~KIND_DIAGNOSTIC);
      }

      doesn't "unlock" anything but clears the "diagnostic" bit so the flag is no longer considered diagnostic. It should be renamed to clear_diagnostic to make that clear and avoid any confusion relating to UnlockDiagnosticVMOptions

        Attachments

          Activity

            People

            Assignee:
            rprotacio Rachel Protacio (Inactive)
            Reporter:
            dholmes David Holmes
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: