Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8067920

Rename InCSetState to something more understandable

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P5
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: tbd
    • Component/s: hotspot
    • Subcomponent:
      gc

      Description

      During the review of JDK-8060025 concerns about the naming for the InCSetState class that contains per-region state during GC for GC to be somewhat suboptimal have been voiced.

      Think of and/or discuss some better naming choice, and implement it.

      See the email thread starting at http://mail.openjdk.java.net/pipermail/hotspot-gc-dev/2014-December/011482.html

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              tschatzl Thomas Schatzl
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: