Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8068396

Rename assert() to vmassert()

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b48
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        Begin the process of eliminating the name clash between the VM's assert() macro and the standard (<assert.h> / <cassert>) assert() macro.

        This first step is to rename assert() to vmassert(), but continue to provide an assert() synonym for backward compatibility. This renaming should be back-ported to earlier versions, to simplify backporting of other changes.

        Once this change and the associated back-porting has been completed, we can incrementally change uses of assert => vmassert in the latest development trees. Once that renaming has been completed, we can remove the backward compatibility synonym from the latest development trees.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  kbarrett Kim Barrett
                  Reporter:
                  kbarrett Kim Barrett
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: