Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8074105

Remove support for downloaded JavaFX classes

    Details

    • Resolved In Build:
      b59

      Backports

        Description

        While investigating JDK-7126229 last week, I see that we still have implementation of JNLPPreverifyClassLoader used in both plugin and webstart.

        This was added for old version of javafx jars that were downloaded by the java installer and verified during install, so that no security dialog for them would show when running the first javafx app/applet. There does not seem to be any reason to maintain them, and their existance complicates the existing classloader chain.

        There is also a whole bunch of code in Plugin2ClassLoader and Applet2ClassLoader to special case when reflection code is executed on these classes (see Applet2ClassLoader.findClass(), JNLP2ClassLoader.findClass(), and Plugin2ClassLoader.needTAoApplyWorkarround())

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  herrick Andy Herrick
                  Reporter:
                  herrick Andy Herrick
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: