Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8077285

jnlp spec version 8.20 is not supported

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8u20, 9
    • Fix Version/s: 9
    • Component/s: deploy
    • Subcomponent:
    • Introduced In Version:
    • Resolved In Build:
      b65

      Backports

        Description

        with the JNLP Specification Maintenance Release 8.20, we should allow to run applications that specify the specification version 8.20 in the jnlp file, but code was not change, so the following jnlp file:
        <?xml version="1.0" encoding="UTF-8"?>
        <jnlp spec="8.0+" codebase="http://oklahoma.us.oracle.com/www/tests/sandbox" >
           <resources>
              <jar href="hello.jar" />
              <j2se version="1.6+" />
           </resources>
           <application-desc main-class="hello"/>
        </jnlp>
        will fail with a LaunchErrorDialog who's detail days that version 8.0+ is not supported.
        furthermore, the error dialog says only versions 6.0, 1.5, and 1.0 are supported.
        (however code in LaunchDesc.isValidSpecificationVersion() allows versions 7.0, 6.0.18. 6.0.10, 6.0, 1.5, and 1.0)
        so the error dialog has not been updated in the past, and the above method should be updated to allow 8.20.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  herrick Andy Herrick
                  Reporter:
                  herrick Andy Herrick
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Due:
                    Created:
                    Updated:
                    Resolved: