Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc
    • Resolved In Build:
      b94
    • CPU:
      generic
    • OS:
      generic

      Description

      The ObjPtrQueue is strongly tied to the SATBMarkQueueSet, and is only used for SATB support. And with recent changes to the handling of the contents of these queues to support eager reclaim of humongous objects, it is no longer true that the queue elements are always valid oops - they can be stale references to reclaimed humongous objects (and maybe eventually even stale young gen object references). So the present class name and comments about it always containing oops should be changed. SATBMarkQueue would be consistent with the set name.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kbarrett Kim Barrett
                Reporter:
                kbarrett Kim Barrett
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: