Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8079255

[TEST_BUG] [macosx] Test closed/java/awt/Robot/RobotWheelTest/RobotWheelTest fails for Mac only

    Details

    • Subcomponent:
    • Resolved In Build:
      b68
    • CPU:
      generic
    • OS:
      os_x

      Backports

        Description

        JDK tested: 9b60
        OS tested: Mac 10.10 , Mac10.9 ,Linux
        Is it a regression? NO
        Is it platform specific? Yes( Fails on Mac and Passes in Linux)
        The is failure reproduced: always
              
        General description:

        ----------System.out:(25/1869)----------
        robot.mouseWheel() failed w/ wheelAmt = -1, correctVal = -1 currentVale = 1
        robot.mouseWheel() failed w/ wheelAmt = 2, correctVal = 1 currentVale = -1
        robot.mouseWheel() failed w/ wheelAmt = -3, correctVal = -2 currentVale = 2
        robot.mouseWheel() failed w/ wheelAmt = 4, correctVal = 2 currentVale = -2
        robot.mouseWheel() failed w/ wheelAmt = -5, correctVal = -3 currentVale = 3
        robot.mouseWheel() failed w/ wheelAmt = 6, correctVal = 3 currentVale = -3
        robot.mouseWheel() failed w/ wheelAmt = -7, correctVal = -4 currentVale = 4
        robot.mouseWheel() failed w/ wheelAmt = 8, correctVal = 4 currentVale = -4
        robot.mouseWheel() failed w/ wheelAmt = -9, correctVal = -5 currentVale = 5
        robot.mouseWheel() failed w/ wheelAmt = 10, correctVal = 5 currentVale = -5
        robot.mouseWheel() failed w/ wheelAmt = -11, correctVal = -6 currentVale = 6
        robot.mouseWheel() failed w/ wheelAmt = 12, correctVal = 6 currentVale = -6
        robot.mouseWheel() failed w/ wheelAmt = -13, correctVal = -7 currentVale = 7
        robot.mouseWheel() failed w/ wheelAmt = 14, correctVal = 7 currentVale = -7
        robot.mouseWheel() failed w/ wheelAmt = -15, correctVal = -8 currentVale = 8
        robot.mouseWheel() failed w/ wheelAmt = 16, correctVal = 8 currentVale = -8
        robot.mouseWheel() failed w/ wheelAmt = -17, correctVal = -9 currentVale = 9
        robot.mouseWheel() failed w/ wheelAmt = 18, correctVal = 9 currentVale = -9
        robot.mouseWheel() failed w/ wheelAmt = -19, correctVal = -10 currentVale = 10
        robot.mouseWheel() failed w/ wheelAmt = 20, correctVal = 10 currentVale = -10
        robot.mouseWheel() failed w/ wheelAmt = -21, correctVal = -11 currentVale = 11
        robot.mouseWheel() failed w/ wheelAmt = 22, correctVal = 11 currentVale = -11
        robot.mouseWheel() failed w/ wheelAmt = -23, correctVal = -12 currentVale = 12
        robot.mouseWheel() failed w/ wheelAmt = 24, correctVal = 12 currentVale = -12
        testPasses = 1, NUMTESTS = 25
        ----------System.err:(5/343)----------
        RobotWheelTest$TestFailsException: Test ran, but failed!
        at RobotWheelTest.start(RobotWheelTest.java:109)
        at com.sun.javatest.regtest.agent.AppletWrapper$AppletRunnable.run(AppletWrapper.java:158)
        at java.lang.Thread.run(Thread.java:745)
        STATUS:Failed.Applet thread threw exception: RobotWheelTest$TestFailsException: Test ran, but failed!

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  alexsch Alexandr Scherbatiy
                  Reporter:
                  pchopra Pooja Chopra (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: