Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8085899

nsk/jdi/AttachingConnector/attach/attach002 Exception java.lang.Error: No appropriate connector (attempts to use dt_shmem)

    Details

      Description

      Test fails in embedded. I am not sure if these tests are expected to work in embedded.

      RULE nsk/jdi/AttachingConnector/attach/attach002 Exception java.lang.Error: No appropriate connector
      RULE nsk/jdi/ListeningConnector/accept/accept002 Exception java.lang.Error: No appropriate connector
      RULE nsk/jdi/ListeningConnector/startListening/startlis002 Exception java.lang.Error: No appropriate connector
      RULE nsk/jdi/ListeningConnector/stopListening/stoplis002 Exception java.lang.Error: No appropriate connector

      Log:
      [2015-06-01T15:21:36.03] # Actual: /export/local/aurora/CommonData/jdk/bin/java -client -Xcomp -client -Xcomp -Dsun.jvm.hotspot.runtime.VM.disableVersionCheck=1 nsk.jdi.AttachingConnector.attach.attach002 -verbose -arch=linux-arm -waittime=5 -debugee.vmkind=java -transport.address=dynamic "-debugee.vmkeys=-client -Xcomp -client -Xcomp"
      [2015-06-01T15:21:46.17] command: /export/local/aurora/CommonData/jdk/bin/java -client -Xcomp -client -Xcomp -Xdebug -Xnoagent -Xrunjdwp:transport=dt_shmem,server=y,address=nskjpdatestchannel1433172104598 nsk.jdi.AttachingConnector.attach.attach002t
      [2015-06-01T15:22:01.88] debugee.stdout> FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_LOAD(196)
      [2015-06-01T15:22:01.88] debugee.stdout> Current thread is 1075450992
      [2015-06-01T15:22:01.88] debugee.stdout> Dumping core ...
      [2015-06-01T15:22:01.88] debugee.stderr> ERROR: transport library not found: dt_shmem
      [2015-06-01T15:22:01.88] debugee.stderr> ERROR: JDWP Transport dt_shmem failed to initialize, TRANSPORT_LOAD(509)
      [2015-06-01T15:22:01.88] debugee.stderr> JDWP exit error AGENT_ERROR_TRANSPORT_LOAD(196): No transports initialized [debugInit.c:730]
      [2015-06-01T15:22:05.47] Exception in thread "main" java.lang.Error: No appropriate connector
      [2015-06-01T15:22:05.50] at nsk.jdi.AttachingConnector.attach.attach002.findConnector(attach002.java:191)
      [2015-06-01T15:22:05.50] at nsk.jdi.AttachingConnector.attach.attach002.attachTarget(attach002.java:132)
      [2015-06-01T15:22:05.50] at nsk.jdi.AttachingConnector.attach.attach002.runIt(attach002.java:98)
      [2015-06-01T15:22:05.50] at nsk.jdi.AttachingConnector.attach.attach002.run(attach002.java:54)
      [2015-06-01T15:22:05.50] at nsk.jdi.AttachingConnector.attach.attach002.main(attach002.java:50)

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mtobiass Mattias Tobiasson (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: