Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8087221

Remove IsJavaVersionAtLeast16() calls from JDK9

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: deploy
    • Resolved In Build:
      b72

      Backports

        Description

        There are many modules in deploy code that call Config.isJavaVersionAtLeast15(), and Config.isJavaVersionAtLeast16().
        Since JDK9 deployment code only supports JRE Version 1.6+, these can all be removed, along with all the code in the else blocks and dependent code (which includes whole modules)
        Removing this would make code look cleaner and remove a lot of dead code.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                herrick Andy Herrick
                Reporter:
                herrick Andy Herrick
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: