Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8087625

Discrepancy between WebEngine#load(String) and WebEngine#loadContent(String)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 7u6
    • Fix Version/s: tbd
    • Component/s: javafx
    • Labels:
      None
    • Environment:

      Windows XP 64 bit
      Java JDK 7u6

    • Subcomponent:
      web

      Description

      When the following HTML is present within the file source passed to WebEngine#load(String) the page loads fine, but when the same HTML content is passed to WebEngine#loadContent(String) a blank page is shown (HTML file path in the first case is on a file system).

      <html>
      <head>
      <link rel="stylesheet" href="http://code.jquery.com/mobile/1.1.1/jquery.mobile-1.1.1.min.css" />
      <script src="http://code.jquery.com/jquery-1.7.1.min.js"></script>
      <script src="http://code.jquery.com/mobile/1.1.1/jquery.mobile-1.1.1.min.js"></script>
      </head>
      <body>TEST</body>
      </html>

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              duke J. Duke (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Imported: