Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8090698

[FXML] "Nested controllers" description should clearly say that controller variable has to be named as "fx:id" + "Controller"

    Details

    • Type: Enhancement
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 8u20
    • Fix Version/s: tbd
    • Component/s: javafx
    • Labels:
    • Environment:

      JDK 1.8.0_20, Win 8, 64 Bit

    • Subcomponent:

      Description

      The "Nested controllers" example in http://docs.oracle.com/javase/8/javafx/api/javafx/fxml/doc-files/introduction_to_fxml.html#nested_controllers should clearly say that the injection point variable annotated with @FXML in fact must end be named following the pattern "fx:id" + "Controller".

      It is confusing to FXML beginners that there is a convention existing about the name's "Controller" suffix which in fact is not told anywhere in that document other than an an example.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mkarg Markus Karg
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Imported: