Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8093954

[packager] Allow for easier configuration of CFBundleVersion for Mac/Mac App Store

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8u20
    • Fix Version/s: 8u40
    • Component/s: deploy
    • Labels:
      None

      Description

      The Info.plist template hard codes a value of 100 for CFBundleVersion and there is no mapping to any value in the bundler to change that value.

      This is a problem in the Mac App Store when you update your application the CFBundleVersion must be greater than the version currently in the app store.

      The format is one to three integers separated by dots.

      ´┐ŻAs a workaround the user can place their own version of the info.plist in the drop in resources with a new version of CFBundleVersion.

        Attachments

          Activity

            People

            Assignee:
            shemnon Danno Ferrin (Inactive)
            Reporter:
            shemnon Danno Ferrin (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported: