Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8097804

JavaFX 64 bit should include 32 bit version to support browsers

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P3
    • Resolution: Won't Fix
    • Affects Version/s: 7u6
    • Fix Version/s: None
    • Component/s: javafx
    • Environment:

      javafx-sdk2.2.0-beta

      Description

      Consider the following situation: User is trying to run JavaFX applet without having JavaFX Runtime installed. He is redirected to http://www.java.com/en/javafx/ page that suggest him or her to select Runtime according to the OS system bitness. On Windows x64 it may lead to installation of JavaFX x64 Runtime. However, most browsers a 32-bit so the app won't work again causing user frustration. JavaFX doesn't seem to work. That can stop adoption.

      One of possible solutions is two install both versions for x64 systems as that will most probably cover all the cases.

        Attachments

        1. screenshot-1.jpg
          15 kB
          Alexander Kuznetcov

          Activity

            People

            • Assignee:
              kcr Kevin Rushforth
              Reporter:
              mrkam Alexander Kuznetcov (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: