Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8097896

UnsatisfiedLinkError when running an FX app using WebEngine on Linux

    Details

      Description

      I have a JavaFX app which uses WebEngine to display an HTML page. I am using javafxpackager to create an install package on windows and on Linux.

      My installed app on Windows works fine. On Linux I get an UnsatisfiedLinkError looking for libxslt.so.1 from /jre/lib/amd64/libjfxwebkit.so.

      My Linux install is Debian 7.5 with XFCE. I have the Oracle 8u5 JVM installed.

      Note, the default installation of Oracle on Debian does not seem to have libxslt.so.1 installed!

      Also, I tried generating an installer on Debian and specifying the libxslt.so.1 as a native dependency for the app, however this still does not work. I tried copying the libxslt.so.1 manually to opt/<app>/runtime/jre/lib/amd64 directory, however the installed app still does not seem to find the file.

      There does not appear to be any way to resolve this problem on Linux and generate a deb package that will work without having to ask end user's to manually install libxslt via the repository.

      To replicate... create any basic JavaFX app with a Webview / WebEngine component that displays some html. Then package your app using javafxpackager on Debian x64 using Oracle 8u5. Install your app on a Debian x64 machine with XFCE and then try running it.

        Attachments

          Activity

            People

            • Assignee:
              shemnon Danno Ferrin (Inactive)
              Reporter:
              drivljfx Driv3l (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: