Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8102136

Material.setBumpMap() should be renamed Material.setNormalMap()

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Won't Fix
    • Affects Version/s: 8
    • Fix Version/s: 8
    • Component/s: javafx

      Description

      Material.setBumpMap() should be renamed Material.setNormalMap(),
      as the map used has an RGB value indicating XYZ normal direction.
      The map currently used by setBumpMap is a normal map as described in this link:
      http://wiki.blender.org/index.php/Doc:2.4/Manual/Textures/Influence/Material/Bump_and_Normal
      These maps definitely have distinct x, y and z values (normal) and changing those components individually has an impact on the visual result.

      In animation production, we use 3 kinds of maps:
      [*] Bump Map : Greyscale value indicating bump
      [*] Normal Map : RGB value indicating XYZ normal direction
      [*] Displacement Map : actually moves the surface of the geometry (expensive)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ckyang Chien Yang (Inactive)
                Reporter:
                jyoon John Yoon (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported: