Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8106438

dtfx.js doesn't always detect Java 6u11 + FF3 on WinXP-SP3 and it forces you into an endless upgrade loop

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: fx1.0.1
    • Fix Version/s: fx1.1
    • Component/s: deploy
    • Labels:

      Description

      I just tried going to some samples on JavaFX.com using FireFox 3.0.4 on Windows XP SP 3 (stock install, nothing extra) with JavaSE 6 update 11 already installed. The page says "Java is required to run JavaFX applications. You will now be redirected to a Java update site to get the latest version". If you click okay it downloads and launches the installer and then tells me I already have it. Then it reloads the page and gives me the original message again. Stuck in a loop. If I hit cancel on the installer then I get the error: The current version of Java doesn't uspport JavaFX (0 - Java Not Enabled). Something is clearly wrong in our detection scripts that it won't detect JavaSE update 11 (and possibly others). I've heard reports of this from others but hadn't seen it myself until today (admittedly I haven't gone to javafx.com in a couple of weeks). This may affect anyone with Update 11 on Windows. I know this didn't happen at the launch because I tested it well, so I'm worried that we introduced some sort of regression with the latest update. Can you try it on your windows computers? On this same computer everything works fine with IE 6.

        Attachments

          Activity

            People

            Assignee:
            jcampaneljfx Jim Campanell (Inactive)
            Reporter:
            jmarinacsunw Joshua Marinacci (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported: