Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8108597

REGRESSION: PathAnimation sample doesn't play

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: fx1.3
    • Fix Version/s: fx1.3
    • Component/s: javafx
    • Labels:

      Description

      This is a regression caused by the fix to RT-3470 .

      When you launch the PathAnimation sample and press the play button, no animation is shown. The timeline is running, though, because if you switch to the boat and back to the car, you can see that the animation is running since it will jump to the right location and then continue. It will stop when it gets back to the beginning (and you can switch back and forth and see it running). If you start the boat animation and go back to the car it will run continuously but the image will disappear for a frame at the end before starting again at the beginning.

      I've verified that the following changeset introduced this regression:

      http://jfxsrc.sfbay.sun.com/javafx/soma/scrum/graphics/runtime/rev/bac3f032bf27

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                loneid Leonid Popov (Inactive)
                Reporter:
                kcr Kevin Rushforth
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported: