Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8113090

Mac: Need to detect old version of Mac OS X and report a meaningful error message

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: fx2.0
    • Fix Version/s: fx2.0
    • Component/s: javafx
    • Labels:
    • Environment:

      Mac OS X 10.5.8

      Description

      JavaFX is only supported on Mac OS X 10.6 or later. We don't currently check the version of Mac OS X, and attempt to run JavaFX anyway. This results in the following cryptic and misleading error message:

      java.lang.UnsatisfiedLinkError: Can't load library: /Users/bcbeck/fx/builds/javafx-sdk2.0-beta/rt/lib/../bin/libmat.dylib

      when what really happened is that .../bin/libmat.jnilib couldn't be loaded, due to 10.6 dependencies, so it tries libmat.dylib which doesn't exist.

      This is compounded by RT-13739 which will cause a Headless exception if running from the JavaFX standalone launcher when trying to report this error message.

      We need to check the version of Mac OS X in QuantumToolkit initialization and throw an exception with a meaningful error message.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              morris Morris Meyer (Inactive)
              Reporter:
              kcr Kevin Rushforth
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported: