Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8113808

Rename SelectionMode enum values

    Details

      Description

      rename MULTIPLE_INTERVAL_SELECTION to MULTIPLE, SINGLE_SELECTION to SINGLE
      Justification: less typing and horizontal 'cost' for developers, as well as one less 'selection' reference, which is already very heavy.

      For example:
      listView.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE_INTERVAL_SELECTION)
      becomes
      listView.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE)

        Attachments

          Activity

            People

            • Assignee:
              jgiles Jonathan Giles
              Reporter:
              jgiles Jonathan Giles
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: