Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8114040

Controls backgrounds are no longer aligned (Regression)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: fx2.0
    • Fix Version/s: fx2.0
    • Component/s: javafx
    • Environment:

      Windows, Ok on Mac

      Description

      A number of controls are not drawn properly in Ensemble. If you look at the sliders in the Interporlator sample or the RadioButtons in the radio buttons sample they are not drawn right. For examples the focus and the dot are off on RadioButtons. See attached image.

      Now the odd thing here is multiple borders on a single Region are not aligned with each other. My feeling is this could be caused by one of two things: either something has changed in Region's painting code or (2) Something has changed in layout that is causing the RadioButtons to be positioned at a weird non-whole-pixel location when they used to be. Then (2) could be highlighting a bug in Region pixel snapping code that we have not found before.

      Other observations:

         * This only happens on Windows, Mac seems fine for me
         * RadioButtons in HelloRadioButton toy are working fine, only Ensemble is broken

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              flar Jim Graham
              Reporter:
              jasper Jasper Potts (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported: