Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8114284

old jre: Java security warning posts a controversy message

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: fx2.0
    • Fix Version/s: fx2.0
    • Component/s: deploy
    • Labels:

      Description


      For public sample sdk (or any internal dtTests sample, there is a contextual issue with the Java security warning message as 6ux users (where ux < than required security version).
      In one place, it says "the required version of Java, 1.6.0_10, is not the latest and may not contain the latest security updates" , and in other place, it says "The application requires an earlier version of Java. Do ...."

      Two issues:
      1) The message should not have been truncated " The application requires an earlier version of Java. Do ..."
      2) Users are warned that their installed Java version is not the latest (but satisfy with fx requirement) and on the other hand, public sdk applicaiton requires an earlier version of Java

      See the attached screenshot for a complete picture

      *** Steps to reproduce:
      0) Install jre 6u10
      1) Install fx promotion - b39 and its public samples
      2) Using any browser, invoke the local public samples (created from step#1) e.g KeystrokeMotion.html

      There will be a controversy Java Security Warning dialog as screenshot attached

        Attachments

          Activity

            People

            Assignee:
            herrick Andy Herrick
            Reporter:
            hungnguy Hung Nguyen (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported: