Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8114491

Change menus to use "disable" instead of "disabled" for the property name

    Details

      Description

      Justification: The MenuItem API does not inherit from Node (it inherits directly from Object). MenuItem (and therefore all subclasses - Menu, RadioMenuItem, CheckMenuItem, CustomMenuItem) has a 'disabled' property that, whilst arguably more readable, is totally inconsistent with Node. This is because Node.disabled indicates that not just the node, but it's entire hierarchy is disabled. At present MenuItem does not have this notion - you can not disable a Menu and have all of it's MenuItem children become disabled. However, should we ever support this in the future (and it seems like a reasonable feature), we do not want to have trampled on disabled. Using disable instead would make us consistent with Node.disable.

        Attachments

          Activity

            People

            • Assignee:
              jgiles Jonathan Giles
              Reporter:
              rbair Richard Bair
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: