Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8115385

JavaFX attempts to install version 2.0.3 on first use when clicking a webstart link

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Cannot Reproduce
    • Affects Version/s: fx2.1
    • Fix Version/s: None
    • Component/s: deploy
    • Labels:
      None
    • Environment:

      Description

      download & unzip the JavaFX samples from the Oracle site ( http://download.oracle.com/otn-pub/java/javafx/2.1.0-b21/javafx_samples-2_1_0-windows.zip )

      open BrickBreaker.html & click the Webstart link, now the JavaFX 2.0.3 installer is downloaded, instead of the expected JavaFX 2.1.0 one (note that trying to start the embedded JavaFX application does download the JavaFX 2.1.0 installer). I have absolutely no clue why this happens, especially since the encoded jnlp_content of the Webstart link is exactly the same as both the encoded jnlp_content of the embedded JavaFX application & the external BrickBreaker.jnlp file.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                igor Igor Nekrestyanov (Inactive)
                Reporter:
                avanelverjfx Anthony Vanelverdinghe (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported: