Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8117099

JavaFx runtime does not prompt to install when it is needed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: fx2.0
    • Fix Version/s: fx2.0
    • Component/s: deploy
    • Environment:

      windows xp 32 and win 7 64

      Description

      tested with b41
      Reproduce steps:
      1. install JRE 170 or later version.
      2. Launch a JavaFX applet in IE, FF or Chrome. Like this http://jfx.sfbay.sun.com/hudson/view/Presidio/job/presidio/label=windows-i586-14/lastSuccessfulBuild/artifact/artifacts/apps/internal/Calculator.html
      Expected: It prompts to install JavaFX runtime
      Actual: it does nothing. When I click the web page, it shows JS errors. I attached screenshots to indicate this issue

      I tried on windows XP 32 bit with IE 8, and windows 7 64 bit with IE 9.

        Attachments

          Activity

            People

            • Assignee:
              igor Igor Nekrestyanov (Inactive)
              Reporter:
              xiaofeya Xiaofeng Yang
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: