Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8118865

Failed to use JavaFX 2.0.0 found at C:\Program Files\Oracle\JavaFX Runtime 2.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Cannot Reproduce
    • Affects Version/s: fx2.0.1
    • Fix Version/s: fx2.1
    • Component/s: deploy
    • Environment:

      Windows Vista Home Premium - SP2 with all the latest updates from MS.
      Java JDK 7 and runtime that comes with the JDK.
      JavaFX 2.0.

      Description

      Unable to run any of the javafx samples.
      Opening the html file in the browser results in the following error:
      ExitException[ 3]java.lang.Throwable: Failed to use JavaFX 2.0.0 found at C:\Program Files\Oracle\JavaFX Runtime 2.0\
      at sun.plugin2.applet.JNLP2Manager.prepareLaunchFile(Unknown Source)
      at sun.plugin2.applet.JNLP2Manager.loadJarFiles(Unknown Source)
      at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)

      Please find trace file attached.

      Was working on JDK 6.
      Just uninstalled JDK 6 fully (including JRE 6) and installed JDK 7 with JRE.

      After that the samples do not startup.
      Tried to launch from Oracle website http://download.oracle.com/otndocs/products/javafx/samples/Ensemble/index.html get the same error.

      JavaFX 2.0 sdk is installed in different directory (not that this setup worked for JDK 6) so uninstalled and reinstalled JavaFX 2.0 into default directory i.e. C:\Program Files\Oracle\JavaFX Runtime 2.0\ but no joy.

      The error msg shows that the directory was found correctly but says "failed to use".

      JDK 7 installation by itself is working fine. I have not tried to reinstall this.







        Attachments

          Activity

            People

            • Assignee:
              ngthomas Thomas Ng (Inactive)
              Reporter:
              artsofticjfx ArtSoftica (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: