Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8119606

Version info in xmlns:fx breaks integration with ALL versions of NetBeans

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 7u40, 8
    • Fix Version/s: 8
    • Component/s: javafx
    • Labels:
      None
    • Environment:

      JavaFX Scene Builder 1.1 Version: 1.1-b35, Changeset: 50e3d7cdf394
      All versions of NetBeans.

      Description

      The added /1 to the xmlns:fx largely breaks integration with all versions of NetBeans.

      The version information
      specified in https://javafx-jira.kenai.com/browse/RT-28599
        and
      implemented in https://javafx-jira.kenai.com/browse/DTL-5739

      Causes the following anomalies, reported in the NetBeans' Bugzilla:

      236624 [74cat] After "Make Controller" project builds cleanly, but won't run or debug
      236621 [74cat] FXML editor - Errors are incorrectly highlighted
      236620 [74cat] Make Controller fails to inject Private variables (control fx:id )
      236559 Using Netbeans "Make Controller" duplicates the fx:controller property, and makes the fxml file non-loadable anymore
      236508 NullPointerException: The description parameter cannot be null

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              svienot Simon Vienot
              Reporter:
              ldasarojfx Lou Dasaro (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported: