Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8125043

System requirements doc is misleading for Linux graphics hardware acceleration

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 7u6
    • Fix Version/s: 7u10
    • Component/s: docs
    • Labels:
      None

      Description

      The JavaFX 2.2 system requirements section lists the requirement for graphics hardware acceleration and contains the following two sentences after the table listing the minimum HW configuration:

          "For Mac OS, JavaFX supports graphic hardware acceleration on any Mac OS X system that is Lion or later.

          On Linux platform, 3D features are supported for Nvidia cards (proprietary drivers only)."

      The latter sentence is misleading, since it isn't just 3D features that are only supported on Nvidia cards on Linux, but graphics hardware acceleration in general. This is especially confusing in light of the previous sentence which talks about graphic hardware acceleration for the Mac.

      The last sentence should be reworded as follows:

          "On Linux platform, graphic hardware acceleration is only supported for Nvidia cards (proprietary drivers only)."

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                nhildebrandt Nancy Hildebrandt (Inactive)
                Reporter:
                kcr Kevin Rushforth
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported: