Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8126703

JRE auto-download servlet needs to be updated to be aware of javafx co-bundle and javafx version query

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P2
    • Resolution: Won't Fix
    • Affects Version/s: 7u6
    • Fix Version/s: None
    • Component/s: deploy
    • Environment:

      7ub16, win7, IE8

      Description

      When set the requiredFXVersion parameter as 5+, and launch the javafx applet.
      There will be a "Warning - Old Version of Java Requested" dialog comes out, saying that "This application would like to use an old version of Java(1.6+) that is not installed on your system...."
      This is wrong since I have 7u6 installed on my machine.

      Steps to reproduce:
      1.Install 7u6 b16
      2.Launch the javafx applet from http://sqeweb.us.oracle.com/deployment2/sheldon/webCases/FXDTManualTest/html/Install_5+_latest.html
      3.If the dialog comes out, the bug is reproducible.




        Attachments

          Activity

            People

            • Assignee:
              ngthomas Thomas Ng (Inactive)
              Reporter:
              yanqchen Sheldon Chen (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: