Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8126767

Incoherent support of DOM specs

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: fx2.1
    • Fix Version/s: 8
    • Component/s: javafx
    • Subcomponent:
      web

      Description

      In DOM Level 2 and Level 3, there is two methods for testing features availability and using these features, but responses are not coherent:

      final WebEngine engine = ...; // after WebView initalization and addition of content
      final Document document = engine.getDocument();
      final boolean supported = document.isSupported("Traversal", "2.0");
      System.err.println("Supported: " + supported); // write "Supported: true"
      if (supported) {
       final DocumentTraversal traversal = (DocumentTraversal) document.getFeature("Traversal", "2.0");
      // fail with following stack trace:
      // java.lang.UnsupportedOperationException: Not supported yet.
      // at com.sun.webpane.webkit.dom.NodeImpl.getFeature(NodeImpl.java:552)
      // [...]

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                uta Alexey Utkin (Inactive)
                Reporter:
                gsutrajfx Gaja Sutra (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported: