Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8126941

Cannot move focus out of JFXPanel

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: 7u6
    • Fix Version/s: None
    • Component/s: javafx
    • Labels:

      Description

      WIth a JFXPanel, focus traversal works INTO the panel but not OUT of it. Therefore, focus traversal (with tab key) is broken on Swing windows with multiple JFXPanels or mixed Swing components and a JFXPanel. As soon as a control inside a JFXPanel gets focus, the focus can be moved only between controls of the same JFXPanel (using the tab key).

        Issue Links

          Activity

          art Artem Ananiev added a comment -
          Duplicate of RT-10919.

            People

            • Assignee:
              art Artem Ananiev
              Reporter:
              wlehmann Werner Lehmann
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported: