Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8128669

SDK must always install the matching runtime version

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: fx2.0, fx2.0.1, fx2.0.2
    • Fix Version/s: fx2.0.2
    • Component/s: install
    • Labels:

      Description

      Currently, if the user already has any version of the runtime installer the SDK installer will not install the corresponding runtime for the SDK.

      SDK installer shall always install the latest RT version.
      1. Currently the SDK installer calls directly the RT msi as there were some deadlock issues we had to work around.
      2. The fix, re-introduction of the wrapper code is not a simple fix

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jqzuo Jennifer Zuo (Inactive)
                Reporter:
                jmcglynn Joe Mcglynn (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported: