Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8129947

[macosx] Clicking on a scrollbar causes crashes on the Mac El Capitan OS

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: 8u45, 9
    • Fix Version/s: 9
    • Component/s: client-libs

      Description

      FULL PRODUCT VERSION :
      java version "1.8.0_45"
      Java(TM) SE Runtime Environment (build 1.8.0_45-b15)
      Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

      ADDITIONAL OS VERSION INFORMATION :
      Mac El Capitan OS

      A DESCRIPTION OF THE PROBLEM :
      Clicking on a scrollbar causes a crash on El Capitan.
      A small example is attached.


      REPRODUCIBILITY :
      This bug can be reproduced often.

      ---------- BEGIN SOURCE ----------
      import java.awt.*;
      import javax.swing.*;

      class ScrolledPane
      extends JFrame
      {
      private JScrollPane scrollPane;

      public ScrolledPane()
      {
      setTitle( "Scrolling Pane Application" );
      setSize( 200, 200 );
      setBackground( Color.gray );
      setDefaultCloseOperation(EXIT_ON_CLOSE);

      JPanel topPanel = new JPanel();
      topPanel.setLayout( new BorderLayout() );
      getContentPane().add( topPanel );

      //Icon image = new ImageIcon( "chanceBlue.gif" );
      JLabel label = new JLabel( "Hello World" );

      // Create a tabbed pane
      scrollPane = new JScrollPane();
      scrollPane.getViewport().add( label );
      topPanel.add( scrollPane, BorderLayout.CENTER );
      }


      public static void main( String args[] )
      {

      // Create an instance of the test application
      ScrolledPane mainFrame = new ScrolledPane();
      mainFrame.setVisible( true );
      }
      }
      ---------- END SOURCE ----------

      1. hs_err_pid1638.log
        43 kB
        Alexander Scherbatiy
      2. ScrolledPane_crash.txt
        82 kB
        Alexander Scherbatiy
      3. ScrolledPane.java
        0.8 kB
        Pardeep Sharma

        Issue Links

          Activity

          pardesha Pardeep Sharma added a comment -
          This is an OS specific issue (OS X El Capitan). Checked this with JDK 8u45 and 8u60 ea b19 in MAC OS X and couldn't reproduce.

          1. Run the attached test case (ScrolledPane.java) in Windows 7 (64-bit).

          2. Checked this for JDK 8u45, 8u60 ea b19, and 9 ea b69.
          Result:
          8u45: OK
          8u60 ea b19: OK
          9 ea b69: OK

          3. In MAC OS X 10.9, the issue is not reproducible. This need to be checked on OS X El Capitan.
          ndcosta Nelson Dcosta added a comment -
          alexsch Alexander Scherbatiy added a comment -
          Crash log is attached.

            People

            • Assignee:
              alexsch Alexander Scherbatiy
              Reporter:
              webbuggrp Webbug Group
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: