Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8129959

DebugLogger has unnecessary API methods

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b71
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        levelCoarserThan, levelCoarserThanOrEqual, levelFinerThan, levelFinerThanOrEqual, all have confusing names and 3 out of four are unnecessary. We really only need levelFinerThanOrEqual, and since java.util.Logger provides the same predicate under name "isLoggable", we should just rename it as such too and simply delegate to the contained j.u.l.Logger:

            public boolean isLoggable(final Level level) {
                return logger.isLoggable(level);
            }


          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  attila Attila Szegedi
                  Reporter:
                  attila Attila Szegedi
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: