Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8132091

Clean up JAXP code that has dependency on Java version string

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: xml
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b96

      Description

      The JAXP API was a standalone API and there was an attempt to keep the code in sync across major versions. This is no longer the case. The code that depended on Java version string, such as isJavaVersionAtLeast and related code, can be removed.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              joehw Joe Wang
              Reporter:
              joehw Joe Wang
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: