Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8139761

Improve Dynalink class nomenclature and package organization

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b89
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        Class naming and package organization in Dynalink should be improved. All package and type names below are presumed to be named relative to the Dynalink package itself. Specifically:

        1. linker.GuardedInvocationFilter should be renamed to linker.GuardedInvocationTransformer. "Filter" implies a predicate; this interface OTOH takes and returns a GuardedInvocation.

        2. a new package for classes supporting the linker package should be introduced, named linker.support. These classes were so far in the support package. The classes in question are: support.CompositeGuardingDynamicLinker, support.CompositeTypeBasedGuardingDynamicLinker, support.DefaultInternalObjectFilter, support.Guards, support.Lookup, support.SimpleLinkRequest, support.TypeUtilities,

        3. MonomorphicCallSite should be renamed to SimpleRelinkableCallSite (in keeping with the principle of naming simplest possible implementations) and moved to support package

        4. ChainedCallSite should be moved to support package

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                attila Attila Szegedi
                Reporter:
                attila Attila Szegedi
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: