Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8140552

ResourceObj copy ctor stack logic breaks with gcc 4.9.2 on some systems

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 10
    • Component/s: hotspot
    • Subcomponent:
    • Verification:
      Verified

      Description

      Investigate why ResourceObj copy ctor stack logic breaks with gcc 4.9.2 and only manifests on certain (mainly OEL) systems. Possibly remove ResourceObj copy ctor altogether.

        Issue Links

          Activity

          dholmes David Holmes added a comment -
          Using b87 I ran java -version on the same machine (sca00bqb) as we saw the crash in:

          http://scaaa637.us.oracle.com/archive/2015/10/2015-10-21-184338.cthaling.dev/

          No crash.

          I then ran the same test compiuler/jsr292/CreatesInterfaceDotEqualsCallInfo.java

          No crash.

          I grabbed the actual failing binary from JPRT and ran java -version

          No crash

          I ran the test using that version

          No crash.

          It seems the issue is not readily reproducible in isolation.
          dholmes David Holmes added a comment -
          Sorry this is not an issue to defer until 10! We need to know why the compiler change caused a problem and why it only manifests on certain systems.

          See also JDK-8140630 for a JDK issue also due to the new compiler.
          iklam Ioi Lam added a comment -
          I attempted to give this bug a more descriptive name. If it's incorrect, please fix it.
          dholmes David Holmes added a comment -
          Is there still an issue here?
          dlong Dean Long added a comment -
          To find out if the problem still exists, backout 8140452.
          gtriantafill George Triantafillou added a comment -
          Tested by backing out change for JDK-8140452 (http://hg.openjdk.java.net/jdk9/jdk9/hotspot/rev/20dff0211ded) and running compiler/jsr292/CreatesInterfaceDotEqualsCallInfo.java. All tests passed.

            People

            • Assignee:
              gtriantafill George Triantafillou
              Reporter:
              dlong Dean Long
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: