Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8140772

Enhance doclint to check for deprecation on packages.

    Details

    • Type: Enhancement
    • Status: New
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 9
    • Fix Version/s: tbd_minor
    • Component/s: tools
    • Labels:
      None
    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      Apparently deprecation of packages were never allowed. We must enhance
      doclint to enforce this, see https://bugs.openjdk.java.net/browse/JDK-8140692.

      Thus we should warn if @deprecated or @Deprecated is present in a package-info.java, (and maybe package.html ?)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jjg Jonathan Gibbons
                Reporter:
                ksrini Kumar Srinivasan
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: