Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8141099

[javadoc] Remove support for @deprecated tags on packages.

    Details

    • Type: Bug
    • Status: Open
    • Priority: P3
    • Resolution: Unresolved
    • Affects Version/s: 9
    • Fix Version/s: tbd_minor
    • Component/s: tools
    • Labels:
      None

      Description

      As of fix for JDK-6481080, @Deprecated annotation is no longer recognized for packages, thus it follows that the @deprecated should also follow the JLS and should not recognize them, a separate bug has been filed to enhance doclint and javac's xlint, to emit warnings if such an annotation or tag exists in packages, see JDK-8140772

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ksrini Kumar Srinivasan
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: