Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8141652

Rename methods Objects.nonNullElse* to requireNonNullElse*

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b93

      Description

      After much discussion:

      The methods Objects.nonNullElse and Objects.nonNullElseGet are to be renamed to fit into the requireNonNull* family of methods.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              rriggs Roger Riggs
              Reporter:
              rriggs Roger Riggs
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: