Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8142474

Test closed/java/awt/Robot/RobotWheelTest/RobotWheelTest fails on ARM

    Details

      Description

      The test closed/java/awt/Robot/RobotWheelTest/RobotWheelTest fails on Linux ARMv6/7 HF platform with the following error message:

      ----------System.out:(21/1562)----------
      robot.mouseWheel() failed w/ wheelAmt = -5, correctVal = -3 currentVale = 0
      robot.mouseWheel() failed w/ wheelAmt = 6, correctVal = 3 currentVale = 6
      robot.mouseWheel() failed w/ wheelAmt = -7, correctVal = -4 currentVale = 2
      robot.mouseWheel() failed w/ wheelAmt = 8, correctVal = 4 currentVale = 6
      robot.mouseWheel() failed w/ wheelAmt = -9, correctVal = -5 currentVale = 3
      robot.mouseWheel() failed w/ wheelAmt = 10, correctVal = 5 currentVale = 10
      robot.mouseWheel() failed w/ wheelAmt = -11, correctVal = -6 currentVale = 2
      robot.mouseWheel() failed w/ wheelAmt = 12, correctVal = 6 currentVale = 14
      robot.mouseWheel() failed w/ wheelAmt = -13, correctVal = -7 currentVale = 11
      robot.mouseWheel() failed w/ wheelAmt = 14, correctVal = 7 currentVale = 19
      robot.mouseWheel() failed w/ wheelAmt = -15, correctVal = -8 currentVale = 4
      robot.mouseWheel() failed w/ wheelAmt = 16, correctVal = 8 currentVale = 15
      robot.mouseWheel() failed w/ wheelAmt = -17, correctVal = -9 currentVale = 4
      robot.mouseWheel() failed w/ wheelAmt = 18, correctVal = 9 currentVale = 19
      robot.mouseWheel() failed w/ wheelAmt = -19, correctVal = -10 currentVale = 16
      robot.mouseWheel() failed w/ wheelAmt = 20, correctVal = 10 currentVale = 30
      robot.mouseWheel() failed w/ wheelAmt = -21, correctVal = -11 currentVale = 12
      robot.mouseWheel() failed w/ wheelAmt = 22, correctVal = 11 currentVale = 28
      robot.mouseWheel() failed w/ wheelAmt = -23, correctVal = -12 currentVale = 5
      robot.mouseWheel() failed w/ wheelAmt = 24, correctVal = 12 currentVale = 26
      testPasses = 5, NUMTESTS = 25
      ----------System.err:(5/343)----------
      RobotWheelTest$TestFailsException: Test ran, but failed!
      at RobotWheelTest.start(RobotWheelTest.java:109)
      at com.sun.javatest.regtest.agent.AppletWrapper$AppletRunnable.run(AppletWrapper.java:158)
      at java.lang.Thread.run(Thread.java:745)
      STATUS:Failed.Applet thread threw exception: RobotWheelTest$TestFailsException: Test ran, but failed!
      ----------rerun:(6/1301)*----------

      JDK version: 8u71 b05
      OS: Ubuntu 14.04
      Platform: ARMv7
      Reproducibility: always

      It could be a dupe of JDK-8079255. If so, then SQE will request a backport to 8u72.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                aivanov Alexey Ivanov
                Reporter:
                dkononenko Denis Kononenko (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: