Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8143205

long delay in Java startup in Frameset when loaded into frame from link

    XMLWordPrintable

    Details

    • Subcomponent:
    • CPU:
      x86_64
    • OS:
      windows_7

      Description

      FULL PRODUCT VERSION :
      Java 1.8.0_65-b17
      happens in earlier versions as well, started in 1.8.0_600-b27, was OK in 1.8.0_51

      ADDITIONAL OS VERSION INFORMATION :
      Windows 7 (Microsoft Windows [Version 6.1.7601])
      Java 1.8.0_65-b17
      Internet Explorer 11 (11.0.9600.18097)

      EXTRA RELEVANT SYSTEM CONFIGURATION :
      Happens on multiple PCs, on different networks and configurations

      A DESCRIPTION OF THE PROBLEM :
      In Internet Explorer only, when a frameset is used, and a page containing an applet tag is loaded into one of the frames using a HTML link in another frame after the frameset is loaded, there is a long (30 second) delay in java start up before the applet appears. If the applet tag is used in a frame during the initial load, the problem does not happen. It is only triggers if a page with an applet tag is loaded into an existing frame using an HTML link, or a javascript load with top.frames[3].location.href = ...

      The delay seems to happen before the Java logo appears during startup. The problem does not occur with Firefox.

      REGRESSION. Last worked in version 8u51

      ADDITIONAL REGRESSION INFORMATION:
      Java 1.8.0_51

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      <html>
      <head>
      <title>Acordex viewer - Test</title>

      </head>
      <frameset cols="28%,72%" framespacing="0">
      <frameset rows="95%,5%">
      <frame name="left" src="Left.htm" frameborder="0">
      <frame name="Bottom" src="Bottom.htm" frameborder="0">
      </frameset>
      <frameset rows="7%,*">
      <frame name="header" src="top.htm" scrolling="no">
      <frame name="news" src="http://www.acordex.com/">
      </frameset>
      </frameset>
      </html>
      ----- left.htm -----

      <HTML>
      <HEAD>
      <title>Left</title>
              <script language="javascript" type="text/javascript">
                  function jsLoadImageViewer() {
                      self.top.frames[3].location.href = "image.htm";
                  }
              
              </script>

      </HEAD>
      <body topmargin="5">
      <A href="javascript:jsLoadImageViewer() ;">Test Click Here</A>
      </body>
      ---- image.htm
      <body>
      <applet codebase=<any applet here>>
      </applet>
      </body>


      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      After clicking link, Java logo appears, then applet loads normally
      ACTUAL -
      After clicking link, applet takes 30 seconds before Java logo appears, then loads.

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      There is no log output because the time delay is occurring during the plugin startup

      REPRODUCIBILITY :
      This bug can be reproduced always.

      ---------- BEGIN SOURCE ----------
      Any applet will do, the problem has to do with Java startup, not the applet itself.
      ---------- END SOURCE ----------

      CUSTOMER SUBMITTED WORKAROUND :
      Not using frames, or loading the frameset initially with the page containing Java

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pardesha Pardeep Sharma
                Reporter:
                webbuggrp Webbug Group
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: