Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8150074

Mobile: Can't build JDK 9 Mobile with Android NDK r10e

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 9-repo-mobile
    • Fix Version/s: 9-repo-mobile
    • Component/s: client-libs
    • Labels:
    • Resolved In Build:
      team

      Description

      The JDK9 Mobile dev repo cannot be built using the latest Android NDK version r10e.

      The changes integrated with this issue will allow the JDK mobile forest to be build with a standalone toolchain that is generated using Android NDK version r10e and targeting platform API level 19.

      We are settling on API level 19 since there are still many Android devices using Android 4.4 (apI level 19).

        Attachments

          Activity

            People

            • Assignee:
              bobv Bob Vandette
              Reporter:
              bobv Bob Vandette
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: