Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8152786

runtime/java/jre should not be marked obsolete in java7

    Details

    • Subcomponent:
    • Resolved In Build:
      b01
    • CPU:
      x86, sparc, x86_64, sparc_64
    • OS:
      solaris_12
    • Verification:
      Not verified

      Description

      Packages:

        developer/java/jdk
        library/java/java-demo
        runtime/java/jre

      allow customers to install the jdk, jre, or java-demos and have the system automatically update them to the latest version of Java available as new versions are released.


      We did it in java6:
      https://bugs.openjdk.java.net/browse/JDK-8023053 (IPS java convenience packages should not be marked obsolete)
      We left runtime/java as not obsoleted package in 6
      but unfortunately in 6 there was runtime/java but in 7 there is runtime/java/jre
      so we ran into
      https://bugs.openjdk.java.net/browse/JDK-8069029(Pkg update problems with obsoletion of JDK 6.)
      https://bug.oraclecorp.com/pls/bug/webbug_print.show?c_rptno=20283334
      Finally we also obsoleted runtime/java in 6

      Java7 and Java8 both have runtime/java/jre
      so this package should not be marked obsolete in 7.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                miroslawzn Miroslaw Niemiec (Inactive)
                Reporter:
                miroslawzn Miroslaw Niemiec (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: