Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8152936

java/lang/Class/GetPackageTest.java needs update to work with newer testng

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b116

      Description

      java/lang/Class/GetPackageTest.java

      Test fails with newer version of testng:

      ----------System.out:(39/2264)----------
      [TestNG] Running:
        java/lang/Class/GetPackageTest.java

      config GetPackageTest.loadFooClass(): success
      test GetPackageTest.testGetPackage(): skip
      org.testng.TestNGException:
      Method public void GetPackageTest.testGetPackage(java.lang.Class,java.lang.String) requires a @DataProvider named : testClasses

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              amlu Amy Lu (Inactive)
              Reporter:
              amlu Amy Lu (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: