Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8080588 VarHandles development
  3. JDK-8154737

Rename VarHandle.compareAndExchangeVolatile to VarHandle.compareAndExchange

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:

      Description

      Renaming VarHandle.compareAndExchangeVolatile to VarHandle.compareAndExchange makes the naming consistent with compareAndSet (although not with weakCompareAndSet, that currently has "plain" semantics), and is less of a mouthful.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              psandoz Paul Sandoz
              Reporter:
              psandoz Paul Sandoz
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: