Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8155214

java/lang/invoke/PermuteArgsTest.java fails due to exhausted code cache

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 8u91, 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Environment:

      -Xcomp

      Backports

        Description

        Caused by: java.lang.VirtualMachineError: out of space in CodeCache for adapters
        at sun.misc.Unsafe.defineAnonymousClass(Native Method)
        at java.lang.invoke.InvokerBytecodeGenerator.loadAndInitializeInvokerClass(InvokerBytecodeGenerator.java:284)
        at java.lang.invoke.InvokerBytecodeGenerator.loadMethod(InvokerBytecodeGenerator.java:276)
        at java.lang.invoke.InvokerBytecodeGenerator.generateCustomizedCode(InvokerBytecodeGenerator.java:618)
        at java.lang.invoke.LambdaForm.compileToBytecode(LambdaForm.java:654)
        ... 49 more

          Activity

          mhaupt Michael Haupt added a comment -
          This seems to be the same issue as observed in JDK-8067005, and the same fix should apply.
          mhaupt Michael Haupt added a comment - - edited
          Applying the fix to 9 proactively; this test imposes some stress on the code cache, and the safeguard CodeCacheOverflowProcessor handling should be in place.
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/dev/jdk/rev/5a48729a7eb6
          User: mhaupt
          Date: 2016-04-27 13:00:10 +0000
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/jdk9/jdk/rev/5a48729a7eb6
          User: lana
          Date: 2016-05-04 18:39:50 +0000

            People

            • Assignee:
              mhaupt Michael Haupt
              Reporter:
              bmoloden Boris Molodenkov
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: